Azure CVO HA - Azure Storage Account 接続により SK プロセスでクラウド共有 HA 上のディスクが削除または欠落している PANIC
- Views:
- 21
- Visibility:
- Public
- Votes:
- 0
- Category:
- cloud-volumes-ontap-cvo
- Specialty:
- microsoft_azure
- Last Updated:
環境
- Azure上のCloud Volumes ONTAP(CVO)HA
- 高可用性(HA)
- ルート ディスク(Azure CVO HA上のPage Blob)が消失しているか、削除されています
- ストレージ アカウントの接続性
問題
Azure CVO HA がパニック状態になり、起動に失敗します。
Panic String: DIAGNOSTIC PANIC Disk deleted or missing on cloud shared HA in SK process config_thread on release 9.9.0 (C)EMS.logPHO_SCAN: pha.obj.scanfailure:ERROR]: ONTAP could not get a list of objects from the object store, 'object_store0', at 'rootsaxxxxxx.blob.core.windows.net', using IP address '10.x.x.x' with error: Operation Timedout.PHO_SCAN: pha.obj.scansuccess:NOTICE]: ONTAP successfully retrieved a list of objects from the object store, 'object_store0'.原因
- Azure CVO HA は、ルートディスクとデータディスクにページ BLOB を使用し、これらのページ BLOB は ONTAP ポート e0d IP (内部)から Azure ストレージアカウント FQDN (例:rootsaxxxxxx.blob.core.windows.net)を使用して HTTPS/HTTP 経由でアクセスされます。
- ストレージアカウントの FQDN から IP への解決は、Azure パブリック DNS、カスタム DNS、または管理 SVM のホストエントリのいずれかを介して行われ、ONTAP ではブート時にルートボリュームが利用可能である必要があるため、この情報が保持されます。
- Microsoft Azure は、ストレージアカウントのルート BLOB への接続が失われた原因は、ストレージアカウントのライブマイグレーションに関するバックエンドのメンテナンス中に問題が発生したことにあると確認しました。
解決策
ストレージアカウントへの接続の問題が解決されると、ルートディスク(ページブロブ)が利用可能になるため、Azure CVO HAが起動します。
追加情報
ルートストレージアカウントにアクセスできないその他の問題については、以下を確認してください。
- Cloud Volumes ONTAP Azure HA - DNS キャッシュが更新されていないため、ONTAP がオブジェクトストアからオブジェクトのリストを取得できませんでした。
- CVO のカスタム DNS のトラブルシューティング - ルートディスクとデータディスクの両方の BLOB および FabricPool に使用される BLOB について
- Azure CVO ノードがオフラインになり、NIC 切断時にシリアルコンソールに「Entering FM state:5」エラーが表示される
- Azure CVO ノードの再起動:「DIAGNOSTIC PANIC Disk deleted or missing on cloud shared HA」
内部情報
内部情報