NDMPバックアップがポート10000での接続確立に失敗する

規定のコンテンツブロック内にのみテキストを追加してください。ソルブループコンテンツの作成の詳細については、こちらをクリックしてください。
環境
- ONTAP 9
- NDMP
問題
- NDMP データ管理アプリケーション(DMA)からの NDMP 要求は、ポート 10000 への接続に失敗します。
- ポート 10000 の NetApp NDMP サーバーに接続できないため、DMA は NDMP ホストまたはバックアップを構成できません。
NDMPへの接続に失敗すると、DMAはNetAppホストへの接続に失敗した、またはホストに到達できなかったことを示すメッセージを返します。 NDMP DMAには様々な種類があり、表示されるメッセージも異なります。 具体的な例をいくつか挙げます(:)
- NetBackup
Validation of the credentials failed. Either the media servers could not be reached or the credentials are invalid. Valid credentials are required for backups to succeed.
- Backup Exec
A communication failure occured when attempting to connect to this server. Some common cause for this error are: the computer name is typed incorrectly, the computer is not powered on, a Backup eec agent is not installed, or the network is improperly configured.
- Veritas
Error ndmp agent write socket error 10054 an existing connection was forcibly closed by the remote host.error ndmp backup of the client HMSI-CATNAS exited with status 41 (network connection timeout)ndmp-data connect-v3 failed , status =-1 (-1)error ndmp backup of the client HMSI-CATNAS exited with status 25 (cannot connect on socket).
- NetWorker
Connecting to NDMP server ... 'ndmp.server'42572:ndmpsup: Timeout reading42573:ndmpsup: Error reading. System Error: An existing connection was forcibly closed by the remote host.42573:ndmpsup: Error reading. System Error: An operation was attempted on something that is not a socket.42605:ndmpsup: Connection to NDMP server timed out.
- NetAppクラスターでは、NDMPサービスが実行されており、NDMPサーバーはポート10000でリッスンしています。
原因
DMAがNetAppシステムに接続できないが、NDMPが有効になっていてポート10000でリッスンしていることが確認されているシナリオでは、DMAからNetAppクラスターへの接続でポート10000がブロックされていることを意味します。
解決策
- ONTAP 9.9.1以前のクラスタでは、NetApp NDMPサービスがファイアウォールポリシーで有効になっています。
- ONTAP 9.10.1以降では、DMAが使用するように設定されているNetApp LIFに必要なLIFサービスポリシーが設定されています。
- DMAからNetAppシステムへのネットワーク接続を確認してください。
- 障害が発生したホストからpingまたはtracerouteを使用して、DMAが使用するように設定されているNetAppホスト名またはLIF IPへの基本的な接続を確認してください。
- ネットワークチームに協力を依頼し、LIFとバックアップサーバー間のネットワークデバイスでポート10000経由の通信が制限されていないか確認してください。
- たとえば、ファイアウォール ポリシーを確認し、ポート 10000 での NDMP リクエストが許可されていることを確認します。
追加情報
内部情報
以下の診断コマンドを実行して、バックアップ サーバーがポート10000経由でストレージにアクセスできるかどうかを確認します。
::> Set Diag
::*>systemshell -node <Node_name>sudo ipfw -ad list | grep <Back_up server IP>