メインコンテンツまでスキップ

VASA Provider - Upgrading NetApp Unified Appliance (UA) causes user-defined Storage Capability Profiles (SCP) to become unusable during datastore provisioning

Views:
19
Visibility:
Public
Votes:
0
Category:
virtual-storage-console-for-vmware-vsphere
Specialty:
virt
Last Updated:

Applies to

  • NetApp Unified Appliance (UA) 9.x
  • VMware vSphere 6.x

Issue

When an in-place upgrade is performed on the UA, any user-created SCPs will no longer be usable while provisioning datastores. This is seen in the following circumstances:

  • Upgrades between major versions, 9.6 > 9.7
  • Upgrades between minor versions, 9.7 > 9.7P1

In this case, three user-created SCPs were created prior to upgrade

any_scp_template

customer_template

customer_template_2

clipboard_ed3e5f9094e0665c46f390f3eec0e918d.png

After upgrade, the datastores are no longer present in the list of selectable SCPs in the datastore provisioning wizard.

clipboard_e33686ea8010796fe6fdab5d380a59b1b.png

The SCPs do appear in VSC > Storage Capability Profile, but the options for Update and Clone are grayed out.

clipboard_e14dcca25de8771dc1bd43efe732a84d4.png

 

 

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

Scan to view the article on your device