メインコンテンツへスキップ

StorageGRID 12.0.x アップグレードがプライマリ管理ノード以降で失敗する

Views:
8
Visibility:
Public
Votes:
0
Category:
storagegrid
Specialty:
esg
Last Updated:

環境

  • NetApp StorageGRID

問題

  • プライマリ管理ノードが正常にアップグレードされた後、StorageGRID の 12.0.x リリースへのアップグレードが失敗します。
  • Grid Manager で、underMaintenance > Software Update > StorageGRID Update の順に選択すると、アップグレードで以下のエラーが報告されます。

Failed to start the upgrade service on one or more nodes. Details: An unknown GDU server error occurred. For more information, see gdu-server.log.

  • FIPS有効化に関連する複数のアラートがアラートページに表示されます。
  • さらに、プライマリ管理ノード(/var/local/log)にあるgdu-server.logファイルには、以下のエラーメッセージが記録されています。

ERROR -- gdu-server: /usr/lib/ruby/3.1.0/tempfile.rb:358:in `create'
ERROR -- gdu-server: /usr/local/lib/site_ruby/bycast/tasks/gdu-server/ssh-add.rb:47:in `add!'
ERROR -- gdu-server: Task failed: "Upgrade Service Start"
ERROR -- gdu-server: #<RuntimeError: Failed to run ssh-add on node ash1psgan01>
ERROR -- gdu-server: /usr/local/lib/site_ruby/bycast/tasks/gdu-server/ssh-add.rb:104:in `rescue in call'
ERROR -- gdu-server: /usr/local/lib/site_ruby/bycast/tasks/gdu-server/ssh-add.rb:89:in `call'
ERROR -- gdu-server: /usr/local/lib/site_ruby/gdu/server.rb:320:in `maybe_run_ssh_add'
ERROR -- gdu-server: /usr/local/lib/site_ruby/gdu/server.rb:114:in `handle_request'
ERROR -- gdu-server: /usr/local/lib/site_ruby/gdu/server.rb:84:in `serve'
ERROR -- gdu-server: /usr/local/lib/site_ruby/gdu/server.rb:60:in `block (2 levels) in start'  

  • サポートバンドルまたはリカバリパッケージをダウンロードしようとすると、以下のエラーが発生して失敗します:

An unknown GDU server error occurred. For more information, see gdu-server.log.

  • ssh-add を使用して SSH 認証エージェントに SSH 秘密鍵を再追加しようとすると、次のエラーが発生して失敗します:

# ssh-add
Enter passphrase for /root/.ssh/id_rsa:
Bad passphrase, try again for /root/.ssh/id_rsa:

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.