メインコンテンツへスキップ

ディスク不足が原因でStorageGRID SGF6112のインストールが失敗する

Views:
14
Visibility:
Public
Votes:
0
Category:
storagegrid
Specialty:
sgrid
Last Updated:

環境

  • NetApp StorageGRID
  • SGF6112アプライアンス

問題

  • 新規インストール中に発生したエラー: 「1 つ以上のドライブが見つからないか応答しません。既存の StorageGRID インストールを検出して起動するのに十分な数の正常なドライブがありません。この状態を修正する必要があります。見つからないか応答しないドライブは HDD0X です」
  • (アプライアンスに挿入されている正常なドライブをすべて取り外しました)
  • 影響を受けるストレージノードは、pre-GRID 環境 (PGE) 状態であるため、インストールを完了できません。
  • LumberjackPGEログ> /tmp/lumberjack/PGE:
    • sgalocalstoragetool.log ドライブが見つかりませんでした:

2025-04-08|12:47:41|notice|load_g_slot_to_bdev  | 2275| no drive found for slot HDD04
2025-04-08|12:47:41|notice|load_g_slot_to_bdev  | 2275| no drive found for slot HDD05

sgalst-last-recovery.json 2つのベイで2つのドライブが見つからないことが報告されます。

"HDD04:state": "missing",
"HDD04:warning:missing_or_unresponsive_drive": "true",
"HDD05:state": "missing",
"HDD05:warning:missing_or_unresponsive_drive": "true",
  • provision.log インストールをスキップするレポート:
[2025-04-08 12:27:00+00:00 SGA] Boot action from sgalocalstoragetool: 'halt_in_installer_with_clobber_warning'
[2025-04-08 12:27:00+00:00 SGA]  Clobber warning token from sgalocalstoragetool: 'missing_or_unresponsive_drive'
[2025-04-08 12:27:00+00:00 SGA]  Clobber warning data from sgalocalstoragetool:  'HDD04 HDD05 '
[2025-04-08 12:27:00+00:00 SGA] Local RAID is missing or broken, or a reboot is needed; not mapping volumes
[2025-04-08 12:27:14+00:00 SGA] Skipping StorageGRID install check because a platform issue was detect during boot
[2025-04-08 12:27:15+00:00 SGA] [2025-04-08T12:27:14.988] - WARNING -- Failed to get SG OS LUN path. Device /dev/mapper/StorageGRID-SG-OS does not exist
[2025-04-08 12:27:15+00:00 SGA] [2025-04-08T12:27:14.988] - INFO -- Not loading synced data from SG OS LUN. Device does not exist

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.