ブロックデバイスが存在しないため、 StorageGRID ノードを起動できません
環境
- NetApp StorageGRID 11.3以降
- Linux ホスト上の Docker コンテナに導入された StorageGRID ノード
問題
- Linux ホストが異常にリブートしたあとに StorageGRID ノードが自動的に起動されません。
- エラーが原因でノードコンテナが「not-running」と報告され、起動できません。
- ブロックデバイスが存在しないため、StorageGRID ノードを手動で開始できません。
出力例:
# storagegrid node start
ERROR: /etc/storagegrid/nodes/<node name>.conf contains errors; cannot start <node name>
Run 'storagegrid node validate <node name>' and correct any errors, then try again.
# storagegrid node validate <node name>
Confirming existence of node <node name>... PASSED
Checking configuration file /etc/storagegrid/nodes/<node name>.conf for node <node name>...
ERROR: <node name>: BLOCK_DEVICE_VAR_LOCAL = /dev/mapper/<node name>
<node name>: /dev/mapper/<node name> does not exist