メインコンテンツへスキップ

Kubernetesクラスタからアクセスされる ONTAP クラスタで、nblade.execsOverLimit エラーが発生しました

Views:
53
Visibility:
Public
Votes:
2
Category:
astra_trident
Specialty:
snapx
Last Updated:

環境

  • Kubernetesクラスター
  • NetApp Astra Trident
  • NFSv3 / v4
  • Ontap 9.8+

問題

  • PersistentVolumeClaims(PVC)は、Trident によってプロビジョニングされ、特定の OpenShift ノードまたはポッドへのマウントが断続的に失敗します。
  • 影響を受けたポッドはContainerCreating 状態が長期間継続します。
  • これらのノードから NFS ボリュームをマウントしようとすると、 mount.nfs プロセスが数分間ブロックされます。
  • ポッドの状態:q-courier-deployment-xxxxxxx-xaaaaa  0/1   ContainerCreating   0   61m   abcs
  • カーネルログ(dmesg):[6xxxx0.3xxxx1] INFO: task mount.nfs:3xxxx1 blocked for more than 983 seconds.
  • ONTAP EMS:

Mon Jan 01 00:00:00 +0100 [node: kernel: nblade.execsOverLimit:error]: The number of in-flight requests from client with source IP XX.YY.ZZ.XX to destination LIF ZZ.YY.XX.YY (Vserver X) is greater than the maximum number of in-flight requests allowed (128). The client might see degraded performance due to request throttling

Sign in to view the entire content of this KB article.

New to NetApp?

Learn more about our award-winning Support

NetApp provides no representations or warranties regarding the accuracy or reliability or serviceability of any information or recommendations provided in this publication or with respect to any results that may be obtained by the use of the information or observance of any recommendations provided herein. The information in this document is distributed AS IS and the use of this information or the implementation of any recommendations or techniques herein is a customer's responsibility and depends on the customer's ability to evaluate and integrate them into the customer's operational environment. This document and the information contained herein may be used solely in connection with the NetApp products discussed in this document.