Kubernetesクラスタからアクセスされる ONTAP クラスタで、nblade.execsOverLimit エラーが発生しました
環境
- Kubernetesクラスター
- NetApp Astra Trident
- NFSv3 / v4
- Ontap 9.8+
問題
- PersistentVolumeClaims(PVC)は、Trident によってプロビジョニングされ、特定の OpenShift ノードまたはポッドへのマウントが断続的に失敗します。
- 影響を受けたポッドは
ContainerCreating状態が長期間継続します。 - これらのノードから NFS ボリュームをマウントしようとすると、
mount.nfsプロセスが数分間ブロックされます。 - ポッドの状態:
q-courier-deployment-xxxxxxx-xaaaaa 0/1 ContainerCreating 0 61m abcs - カーネルログ(dmesg):
[6xxxx0.3xxxx1] INFO: task mount.nfs:3xxxx1 blocked for more than 983 seconds. - ONTAP EMS:
Mon Jan 01 00:00:00 +0100 [node: kernel: nblade.execsOverLimit:error]: The number of in-flight requests from client with source IP XX.YY.ZZ.XX to destination LIF ZZ.YY.XX.YY (Vserver X) is greater than the maximum number of in-flight requests allowed (128). The client might see degraded performance due to request throttling