AutoSupportが次のエラーで配信に失敗します。「Operation timed out in ONTAP」
環境
- ONTAP 9
- AutoSupport
- HTTPS
- SMTP
- 透過的なプロキシ/ファイアウォール
問題
ASUPのデスティネーションに到達したタイムアウトが原因で、クラスタ内の1つ以上のノードがASUP(AutoSupport)データの送信に失敗しました。 このエラーを報告するさまざまなコマンドの例については、以下を参照してください。
- Command
system node autosupport check show-details
レポートError: Timeout was reached when connecting to the server - 'support.netapp.com'
例:
cluster1::> system node autosupport check show-details -node cluster1-1a
Node: cluster1-1a
Category: https
Component: https-put-destination
Status: failed
Detail: HTTPS PUT connectivity check failed for destination:
https://support.netapp.com/put/AsupPut/. Error: Timeout
was reached when connecting to the server -
'support.netapp.com'
Corrective Action: Possible network configuration issue. Ensure that you
have network connectivity Component: https-post-destination
Status: failed
Detail: HTTPS POST connectivity check failed for destination:
https://support.netapp.com/asupprod/post/1.0/postAsup.
Error: Timeout was reached when connecting to the server
- 'support.netapp.com'
Corrective Action: Possible network configuration issue. Ensure that you
have network connectivity
...
Category: on-demand
Component: ondemand-server
Status: failed
Detail: AutoSupport OnDemand connectivity check failed for
destination:
https://support.netapp.com/aods/asupmessage. Error:
Timeout was reached when connecting to the server -
'support.netapp.com'
Corrective Action: Possible network configuration issue. Ensure that you
have network connectivity
Category: configuration
Component: configuration
Status: ok
Detail: No confhistory iguration issues found.
5 entries were displayed.
- Command
system autosupport history show
レポートtransmission-failed Failed to connect to support.netapp.com ... Operation timed out
例:
cluster1::*> system autosupport history show -node * -fields node,seq-num,status,error,destination
node seq-num destination status error
---------- ------- ----------- ------ -----
node1-01 762159 smtp ignore
node1-01 762159 http transmission-failed Failed to connect to support.netapp.com port 443: Operation timed out
notifyd.log:
errormessage: Closing connection #0
のあとにHTTP/SMTPエラーが続く場合:
例(HTTPS):
(message: Trying 216.240.21.18...
(message: Failed to connect to support.netapp.com port 443: Operation timed out)
例(SMTP):
(message: Trying MAIL_HOST_IP...
(message: Operation timed out)
原因
- 「Operation timed out」は、 ノードからsupport.netapp.com またはSMTPサーバへのネットワーク問題があることを示します。
- AutoSupport転送はノードからルーティングできましたが、デスティネーション( HTTPSの場合はsupport.netapp.com)に到達できなかったか、応答を受信できませんでした。これには次のような関係があります。
- ルーティング設定
- ファイアウォールの設定
- トランスペアレントプロキシ設定
- ONTAPクラスタ構成が正しくない
解決策
- ネットワーキングチームと協力して、次のことを確認します。
- ファイアウォール/透過型プロキシは、ONTAPからの接続(ACLなど)を許可する必要があります。
- すべてのクラスタ管理LIFとノード管理LIFのIPアドレスを許可します。
- 適切なポートでsupport.mc.comへのアウトバウンドアクセスを許可するようにファイアウォールが設定されていることを確認しNetAppます。
- HTTPS: 443
- SMTPS: 587
- SMTP: 25
- ファイアウォール/透過型プロキシは、ONTAPからの接続(ACLなど)を許可する必要があります。
その他のあまり一般的でないソリューション:
- ONTAPで使用されるルートがデスティネーション(support.netapp.comまたはSMTPサーバ)に到達できることを確認する
- AutoSupport通信を妨げる可能性のあるIPアドレスがネットワークに重複していないことを確認します。
- e0M(設定されている場合) が管理LIFと同じサブネットにあることを確認する
- ONTAPでルーティングテーブルが正しく設定されていること、および管理LIFで使用されるサブネットのデフォルトゲートウェイがノードルーティングテーブルにあることを確認する。
追加情報
注:
- AutoSupport 転送は、ノード管理LIFとクラスタ管理LIFの両方で発生します。
- 同じサブネット内にクラスタ間LIFと管理LIFが設定されている場合、またはクラスタ間ゲートウェイに静的ルートに関連付けるメトリックの重みが低く、そのルートをクラスタ間LIFに関連付けると、管理トラフィックはクラスタ間LIFを経由しようとします。
- この問題を回避するために、インタークラスタLIFと管理LIFを別 々 のサブネットに設定してください
- ネットワークルーティングによっては、外部ファイアウォールによってブロックされ、AutoSupport接続とNTP接続が 失敗する可能性があります。
network interface modify -vserver vserver name -lif intercluster LIF -status-admin down
を実行してこれを一時的にテストし、トラフィックが管理LIFを使用していることを確認します。- 確認したら、LIFを再度オンラインにします。
network interface modify -vserver vserver name -lif intercluster LIF -status-admin up
- 到達するには
notifyd.log -
::> node run -node <node_name> -command rdfile /etc/log/mlog/notifyd.log