AutoSupport がエラー:Operation timed out in ONTAP で配信に失敗する
環境
- ONTAP 9
- AutoSupport
- HTTPS
- SMTP
- トランスペアレントプロキシ/ファイアウォール
問題
タイムアウトによりASUPの送信先に到達できず、クラスタ内の1つ以上のノードがASUP(AutoSupport)データの送信に失敗します。 このエラーを報告する可能性のある各種コマンドの例は以下のとおりです:
- コマンド
system node autosupport check show-details
レポートError: Timeout was reached when connecting to the server - 'support.netapp.com'
例:
cluster1::> system node autosupport check show-details -node cluster1-1a
Node: cluster1-1a
Category: https
Component: https-put-destination
Status: failed
Detail: HTTPS PUT connectivity check failed for destination:
https://support.netapp.com/put/AsupPut/. Error: Timeout
was reached when connecting to the server -
'support.netapp.com'
Corrective Action: Possible network configuration issue. Ensure that you
have network connectivity Component: https-post-destination
Status: failed
Detail: HTTPS POST connectivity check failed for destination:
https://support.netapp.com/asupprod/post/1.0/postAsup.
Error: Timeout was reached when connecting to the server
- 'support.netapp.com'
Corrective Action: Possible network configuration issue. Ensure that you
have network connectivity
...
Category: on-demand
Component: ondemand-server
Status: failed
Detail: AutoSupport OnDemand connectivity check failed for
destination:
https://support.netapp.com/aods/asupmessage. Error:
Timeout was reached when connecting to the server -
'support.netapp.com'
Corrective Action: Possible network configuration issue. Ensure that you
have network connectivity
Category: configuration
Component: configuration
Status: ok
Detail: No confhistory iguration issues found.
5 entries were displayed.
- コマンド
system autosupport history show
レポートtransmission-failed Failed to connect to support.netapp.com ... Operation timed out
例:
cluster1::*> system autosupport history show -node * -fields node,seq-num,status,error,destination
node seq-num destination status error
---------- ------- ----------- ------ -----
node1-01 762159 smtp ignore
node1-01 762159 http transmission-failed Failed to connect to support.netapp.com port 443: Operation timed out
notifyd.log:
エラーmessage: Closing connection #0
の後にHTTP/SMTPエラーが続く場合:
例(HTTPS):
(message: Trying 216.240.21.18...
(message: Failed to connect to support.netapp.com port 443: Operation timed out)
例(SMTP):
(message: Trying MAIL_HOST_IP...
(message: Operation timed out)
- ユーザは次のEメール通知を受け取ります:
Unable to send autosupport. productTrapData = AutoSupport mail (HA Group Notification from Nodename (USER_TRIGGERED (ALL:)) NOTICE) was not sent. The system will drop the message. productSerialNum = 1-80-0000xx
原因
- 「Operation timed out」は、ノードからsupport.netapp.com またはSMTPサーバへのネットワークに問題があることを意味します
- AutoSupport送信はノードからルーティングできましたが、宛先(support.netapp.com HTTPSの場合)に到達できなかったか、応答が返されませんでした。これは、次のことに関連している可能性があります。
- ルーティング設定
- ファイアウォール構成
- トランスペアレント プロキシ設定
- ONTAPクラスタ設定が正しくない
解決策
- ネットワーク チームと協力して、次を確認します:
- ファイアウォール/透過型プロキシは、ONTAPからの接続(例:ACL)を許可する必要があります
- すべてのクラスタおよびノード管理LIFのIPアドレスを許可リストに登録する
- いずれかのファイアウォールが、適切なポートで support.netapp.com へのアウトバウンドアクセスを許可するように設定されていることを確認する
- HTTPS:443
- SMTPS:587
- SMTP:25
- ファイアウォール/透過型プロキシは、ONTAPからの接続(例:ACL)を許可する必要があります
その他のあまり一般的でない解決策:
- ONTAPで使用されるルートがデスティネーション(support.netapp.comまたはSMTPサーバ)に到達できることを確認する
- ネットワーク内にAutoSupport通信を妨げる重複IPアドレスがないことを確認する
- e0m(設定されている場合) がmgmt lifsと同じサブネット上にあることを確認する
- ONTAPでルーティングテーブルが正しく設定されていること、およびmgmt LIFで使用されているサブネットのデフォルトゲートウェイがノードルーティングテーブルに含まれていることを確認する。
追加情報
注:
- AutoSupport の転送はノード管理LIFとクラスタ管理LIFの両方で発生することがあります
- クラスタ間LIFと管理LIFが同じサブネットに設定されている場合、またはクラスタ間ゲートウェイが静的ルートに関連付けるメトリックの重みが低い場合、ルートがクラスタ間LIFに関連付けられていると、管理トラフィックはクラスタ間LIFを通じてトラフィックを通過しようとします
- クラスタ間LIFと管理LIFを異なるサブネットに設定して、この問題を回避してください
- ネットワーク ルーティングによっては、外部ファイアウォールによってブロックされ、AutoSupport およびNTP接続が失敗します
- 一時的にテストするには、
network interface modify -vserver vserver name -lif intercluster LIF -status-admin down
を実行してトラフィックがmgmt LIFを使用していることを確認します - 確認できたら、再度LIFをオンラインにします
network interface modify -vserver vserver name -lif intercluster LIF -status-admin up
- 一時的にテストするには、
notifyd.log -
::> node run -node <node_name> -command rdfile /etc/log/mlog/notifyd.log
に到達するには